Commits


must use safe iteration over file index entries


make 'got update' remove directories in a checkout with path prefix


rename misleadinly named field in struct collect_missing_entry_args


improve wording of a comment in tree_checkout()


make 'got update' remove empty directories


make got_repo_get_path() return const char *


make 'got update' remove files which were deleted


ensure that 'got update' stays on the current branch


add a basic 'got update' command; does not merge files yet


fix 'same path prefix' check during checkout


fix got_worktree_get_repo_path()


remove useless strdup from got_worktree_get_repo_path()


verify path prefix when checking out into existing work tree


don't bother opening trees outside of path prefix


don't bother opening a blob if checkout will skip it


rename add_file_on_disk() to blob_checkout()


make checkout skip blobs already recorded in file index


introduce macros for status codes


signal existing files in checkout progress output


allow checkout on top of an existing tree


remove redundant existence check


preparation for idempotent checkout: read exisiting file index


try to sync file index to disk if checkout hits an error


store parsed head reference in struct got_worktree


store base commit of each blob in file index