Commits


make open_packed_object() expect a pack instead of a repo


remove unused parameter of open_delta_object()


don't redundantly open pack file in dump_delta_chain_to_file()


don't open pack redundantly in dump_delta_chain_to_mem()


remove unused parameter from functions resolving packfile deltas


remove unused parameter of open_packfile()


remove unused parameter of get_packfile_path()


remove unused parameter of get_object_idx()


move packidx header initialization to a separate function


don't store copies of packfile paths in each delta


fix leak in dump_delta_chain_to_file()


fix leaks in resolve_offset_delta()


fix more memleaks


only unmap map if non-NULL in got_pack_close()


fix reading ref deltas


rename zbuf to inflate


add a compile time switch to read pack index with read(2)


add compile-time switch which disables mmap for pack files


fall back to read() as intended if mapping packfile fails


read pack files with mmap


don't verify pack index SHA1 upon regular access


simplify more code which assumed deltas could span mulitple packs


wrap overlong lines


only search one pack file while resolving deltas


access pack index files with mmap()