Commits


rename zbuf to inflate


undo previous; too much mixup in one data structure


store recently accessed objects at front of cache lists


allow got_object_idset_remove() to retreive data pointer


undo previous; it broke tog(1) with openssl repo


iter_node insertion hack in commit graph shouldn't be needed


store commit timestamps as 'struct tm' in UTC


got log: allow first-parent traversal with the commit graph


remove false statement in comment


tweak add_node_to_iter_list for clarity; no functional change


improve comment


fix endless loop in commit graph


ensure commit graph iterations see all new commits being added


commit graph support for tog(1)


rename commit graph's iter_candidates to iter_list


remove got_commit_graph_contains_object() Put equivalent functionality into fetch_commits_up_to() instead.


introduce got_commit_graph_fetch_commits_up_to()


introduce got_commit_graph_contains_object


promote commit graph's open_commit() helper to public API


replace inline code with call to open_commit() helper


rename got_parent_id to got_object_qid; better generic name


do not store commits in the commit graph; saves memory


remove unused function


parse commit timestamps when opening commits


move parse_commit_time() to object.c and make public API