Commits


rename zbuf to inflate


add a compile time switch to read pack index with read(2)


add compile-time switch which disables mmap for pack files


fall back to read() as intended if mapping packfile fails


read pack files with mmap


don't verify pack index SHA1 upon regular access


simplify more code which assumed deltas could span mulitple packs


wrap overlong lines


only search one pack file while resolving deltas


access pack index files with mmap()


don't needlessly copy packidx when caching it


use binary search to find objects in pack index


use macro instead of literal ".pack"


use macro instead of literal ".idx"


use strlcpy instead of strncpy


remove unnecessary forward declaration


use local variable to save screen estate in got_packidx_open()


wrap overlong lines


turns out on-disk path of pack file may not match its hash Fixes reading a repo with a pack idx and file dated June 2011, where the filename does not contain the actual packfile SHA1.


fix bogus free() in error path of cache_pack()


move got_opentmp* functions to public API; used from tog


offsets in pack files should not make us seek beyond EOF


store fd instead of FILE in struct got_pack to prepare privsep


read object headers with privsep


put a limit on delta chain recursion