Commits


implement fork+exec (and by the way, fix the build...)


allow filtering history by paths in 'got log'


scan upwards for git repositories


provide a compile-time toggle for object caching


rename zbuf to inflate


add an object id cache which backs the object cache


undo previous; too much mixup in one data structure


store recently accessed objects at front of cache lists


add some disabled refcount debug code


size object caches independently of each other


add a commit cache as well


no need to manually count elements of a set


add a tree object cache to struct got_repository


introduce struct got_object_cache


implement repository object cache via object_idset


remove debug output


add a very simple object cache


try to infer repository path from work tree


rename 'refs' to 'reference'


remove GOT_ERR_NO_MEM, we can just use errno in those cases


rename the library-internal headers again to a common prefix


move delta cache into struct got_pack


add struct got_pack; some preparation for mmap, which isn't used yet


revert the pack file handle cache again; needs more thought


start caching file handles to packfiles