Commits


include <limits.h> instead of <sys/limits.h>; patch by Thomas Klausner


rename got_error_prefix_errno() to got_error_from_errno()


while (1) -> for (;;)


got_error_from_errno -> got_error_prefix_errno also add got_error_prefix_errno2 and got_error_prefix_errno3 which should hopefully all be merged into a single function with variadic args (but can't alloc mem)


check for errors from close(2)


check for errors from fclose()


there's no point in embedding the object header in commits


eliminate got_object_open() round-trip when opening commits


don't be noisy on stderr when Ctrl-C is hit


abort checkout operations cleanly when Ctrl-C is hit


back out mini-commits; no significant performance difference


make got-read-pack pre-seed the main process mini commit cache


rename got_commit_object_mini to got_mini_commit_object


add a mini-commit object for use by commit graph


fix 'make PROFILE=1' build


start reading pack files with privsep; still WIP


implement fork+exec (and by the way, fix the build...)