Commits


rename got_parent_id to got_object_qid; better generic name


move got_opentmp* functions to public API; used from tog


read object headers with privsep


rename 'refs' to 'reference'


verify diff output in blob diff test


remove GOT_ERR_NO_MEM, we can just use errno in those cases


fix memleak in test helper function print_tree_object()


use pledge(2) in regression tests


use stricter CPPFLAGS from mpi


fix repos path argument processing in repository_test


move got_sha1.h to private lib directory


public API is now independent of sha1.h and zlib.h


make length of id string an implementation detail


remove got_parse_object_id(), add got_object_open_by_id_str() instead


make struct got_object_id opaque


make struct got_blob_object opaque


make diff tests silent by default


add output file argument to got_diff_tree


don't assume objects IDs are sorted by their values in packidx


more progress on reading packed/deltified objects


in repository_test.c, make 'verbose' a static variable


make repository test less verbose by default


make the read_log() tests fail if some objects cannot be read


make tests print 'ok' if they pass


Make struct got_object opaque to users of the library