Commits


rename tree-specific fileindex diff callbacks


remove redundant condition check in cmp_entries()


make cmp_entries() operate on paths instead of structs


move forward declaration of diff_fileindex_tree() further down


move definition of cmp_entries() closer to point of use


turns out in_same_subdir() check is mostly redundant


simplify in_same_subdir()


eliminate code duplication in cmp_entries() and in_same_subdir()


eliminate redundant strlen() call inside in_same_subdir()


eliminate redundant strlen() call in cmp_entries()


eliminate code duplication in cmp_entries()


invert same subdir check in cmp_entries(); no functional change


remove unused parameter of in_same_subdir()


happy new copyright year


fix bug where update got confused by sub-sub directories


fix more bugs in the update walk and add more tests


change GOT_INDEX_ENTRY prefix to GOT_FILEIDX


don't bother with memcpy for hdr in got_fileindex_read()


flush the file index after writing it


don't bother with memcpy of header when writing the file index


fix various issues in new update implementation


introduce special error code for a corrupt file index


implement checkout+update as single-pass diff between file index and tree


replace use of got_pathset in worktree code with RB tree


use RB tree directly instead of a pathset in file index code