Commits


got-read-gitconfig: send key-value pairs for extensions Most extension allow only for a boolean value so the current behaviour of just sending the extension with a trueish value is fine. However, some extensions that we could eventually support (like "objectformat") have a string value. This is a preparatory step towards that. ok stsp@


replace got_repo_get_gitconfig_extensions with got_repo_has_extension got_repo_get_gitconfig_extensions is only used in gotadmin to check if the preciousObjects extension is active; let's replace it with a function that just checks whether a certain extension is active. It simplifies future changes to the extensions handling. ok stsp@


fix building of few regress after got_object_id_hex was introduced and used in error.c, the building of delta, deltify and path failed due to missing symbols. Spotted by stsp and tracey, ok stsp


got_object_open: copy whole id not just the sha1 ok stsp@


introduce got_error_checksum ok stsp@


introduce got_object_id_hex to replace some got_sha1_digest_to_str() It's an analogous to got_object_id_str but writes to the given buffer. ok + improvements by stsp@


rename a function for clarity


add a TODO item regarding missing client-side pack content verification


typo and style(9): do not use function calls in initialisers. ok stsp@


fix mistaken instances returning NULL instead of err While here, for consistency, check dup() return value for -1 rather than < 0. ok stsp@


fix missed doc update of new 'got fetch' behaviour ok stsp@


delete unused code serializes an id to a local buffer before before returning. ok stsp


yet another gotwebd TODO writing everything down to avoid forgetting stuff...


one more TODO for gotwebd


add an arrow after "more" as per jamsek suggestion


gotwebd: fix briefs/tags navigation overlap Introduces a separate field for the "next" button (now called "More") and adjusted the CSS/HTML so it's used. Finally, drops the old code used to handle the pagination for the BRIEFS/COMMITS cases. Needs a small hack for the time being, setting the action to TAGS. This is due how qs->action is changed in gotweb.c while handling the request. ok jamsek


zap trailing whitespace


another memcmp -> got_object_id_cmp


use got_object_id_cmp instad of memcmp where possible in object_parse.c ok stsp@


typo in comment it serializes the struct got_imsg_tree_entry, not tree_object. grep aid.


add test coverage for new 'got fetch' default behaviour


got: make fetch default to the work tree's current branch As per stsp's todo item, if invoked in a work tree, make 'got fetch' default to fetching the work tree's current branch instead of the branch pointed to by the remote repository's HEAD. ok stsp@ and op@


add a few TODOs for got patch and gotwebd


got_imsg_commit_object: use struct instead of buffer for id ok stsp@


got_imsg_object: use struct instead of buffer for id ok stsp@